ubuntu 编译安装php5.4以上版本

先安装必须的依赖库:

sudo apt-get -y install autoconf && \

sudo apt-get -y install libxml2-dev && \

sudo apt-get -y install bzip2 && \

sudo apt-get -y install libcurl3-openssl-dev && \

sudo apt-get -y install libcurl4-gnutls-dev && \

sudo apt-get -y install libjpeg-dev && \

sudo apt-get -y install libpng-dev && \

sudo apt-get -y install libxpm-dev && \

sudo apt-get -y install libfreetype6-dev && \

sudo apt-get -y install libt1-dev && \

sudo apt-get -y install libmcrypt-dev && \

sudo apt-get -y install libmysql++-dev && \

sudo apt-get -y install libxslt1-dev && \

sudo apt-get -y install libbz2-dev

 

软链接库文件:

cd /usr/lib && \

ln -s /usr/lib/x86_64-linux-gnu/libXpm.so . && \

ln -s /usr/lib/x86_64-linux-gnu/libXpm.a . && \

ln -s /usr/lib/x86_64-linux-gnu/libXpm.so.4 . && \

ln -s /usr/lib/x86_64-linux-gnu/libXpm.so.4.11.0 . && \

echo ‘successful!’

 

下载最新php源码,编译安装:

cd /opt && \

sudo mkdir src && \

cd src && \

sudo wget http://us1.php.net/distributions/php-5.4.14.tar.gz && \

sudo tar zxvf php-5.4.14.tar.gz && \

cd php-5.4.14 && \

sudo ./configure \

–prefix=/opt/php \

–with-mysql=mysqlnd \

–with-mysqli=mysqlnd \

–with-pdo-mysql=mysqlnd \

–with-config-file-path=/opt/php/etc \

–with-zlib \

–with-curl \

–with-curlwrappers \

–with-mcrypt \

–with-gd \

–with-openssl \

–with-mhash \

–with-xmlrpc \

–with-jpeg-dir \

–with-png-dir \

–with-xpm-dir \

–with-freetype-dir \

–with-zlib-dir \

–enable-shared \

–enable-fpm \

–enable-xml \

–disable-rpath \

–enable-safe-mode \

–enable-bcmath \

–enable-shmop \

–enable-sysvsem \

–enable-inline-optimization \

–enable-mbregex \

–enable-mbstring \

–enable-gd-native-ttf \

–enable-pcntl \

–enable-sockets \

–enable-zip \

–enable-soap

 

不出问题的话就执行最后一步编译安装:

sudo make && sudo make install

Tagged: , , ,

Comments are closed.